Jaguar E-Pace Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter · #1 ·
Hi all,

after cold weather started I got several times P229E fault code which means

P229E Possible Causes
Faulty Nitrogen Oxide (NOx) Sensor Bank 2
Nitrogen Oxide (NOx) Sensor Bank 2 harness is open or shorted
Nitrogen Oxide (NOx) Sensor Bank 2 circuit poor electrical connection

as I remember dealer in South Nicosia made some repairs according to the recall in September 2019.

I think it caused by harness or electrical connection because CEL light lid several days after clear itself.

I booked service for tomorrow but dealer in North Nicosia (other dealer which sold vehicle) thinks that it is caused by AdBlue fluid which I filled in July 2019 from 3rd party seller. And they allegged that it is not covered under warranty.

Anyway as I know there is a factory fault regarding DPF location and driving short distances caused problem.

I dont think it is costly DPF or NOx sensor fault, most probably electrical harness of NOx sensor.

If you have similar problem / situation please share with me
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #2 ·
Hello,

I just wanna update

I picked up vehicle from dealer, it was electric harness fault of bank 2 NOx sensor.

It is repaired under warranty and they didnt charge any money.
 

·
Registered
Joined
·
8 Posts
Hi,

I have been getting the same code on my 2018 epace as well. The EML is a bit sporadic. Comes and goes randomly. For me, strangely, have noticed this during motorway runs. Do you know what causes this?
 
1 - 3 of 3 Posts
Top